MDLog:/sysadmin

The Journal Of A Linux Sysadmin

PHP5 in CPanel/WHM

| Comments

After a long time being supported only as beta (and this by CPanel meaning no support at all), CPanel is finally offering full support for PHP5 on all its latest versions – 10.8.2 – (Stable/Release/Current). I have been using PHP5 on some CPanel servers for a long time without any problems, but now probably they will push towards making this the default choice. Still PHP 4.4.2 is the default version that CPanel will install, but I assume that this will change soon. So it might be a good idea to try to upgrade to PHP5 (or start updating your applications to work on PHP5 as this will soon be needed).

We can choose from various versions of PHP5: 5.0.4, 5.0.5, 5.1.2, 5.1.4… Hmm I feel that they could have added some more :–). My choice was (as I assume most of the peoples will do) the latest version available PHP 5.1.4… Anyway I have not seen any problems on the servers I am using php5 (centos/rhel) besides some application incompatibilities that are being worked on by the developers.

To upgrade your CPanel to PHP5 just use the regular buildapache method. For more details you can see my previous post: “Upgrade php on CPanel/WHM”.

Comments