MDLog:/sysadmin

The Journal Of A Linux Sysadmin

CPanel Upgrade: Apache 1.3.36

| Comments

Today if you will log in any CPanel’s server WHM you will see a big, red notification warning with the following text:

“You are running an insecure Apache setup. You should run /scripts/easyapache or if you are running cPanel 7.1.9 or later (click here) to upgrade to a newer version as soon as possible to avoid your system being compromised.”

I said wow, they have finally decided to move to apache2… But when I checked it out, again a big disappointment… Still apache1, and the upgrade is about version 1.3.16. Nevertheless I have done the upgrade on all the CPanel servers I mange (some Stable, most of them running the Release version) and all went smooth without any problems.

The upgrade will update the following: Apache 1.3.36 -> 1.3.36 FrontPage 5.0.2.2635 -> 5.0.2.2635.SR1.2 mod_ssl 2.8.25 -> 2.8.27

So accordingly to CPanel notification you should go ahead and complete this upgrade as soon as possible.

As seen in the CPanel forums many peoples had problems with this upgrade, so use it with care. I had not encountered any problems myself (Centos4 and RHEL3/4 servers with Stable and Release). Still in case you do this and encounter any problems, open a support ticket with CPanel support. In my opinion they should hide that big red warning until they fix the problems many peoples had. Obviously many peoples will click on that once they see it. You have been warned!

Comments